Operations slowdown
Incident Report for General Caster
Postmortem

The slowdown affected most of users.

The problem was due to an unexpected high number of operations performed concurrently by the users.

Posted Oct 20, 2023 - 10:45 UTC

Resolved
This incident has been resolved.
Posted Oct 19, 2023 - 19:30 UTC
Investigating
We are currently investigating this issue.
Posted Oct 19, 2023 - 16:30 UTC
This incident affected: Monday.com Integrations.